Page 1 of 1

Bug Extracting ZIP

Posted: Sat Oct 06, 2012 7:15 pm
by CTassisF

I think I found a bug when extracting ZIP files using Keka.
I downloaded this "" software, extracted it using Keka, tryed to open it and it didn't start. After debugging it and searching the web I found that this issue was being caused because a file (/Applications/ wasn't with execute (+x) permissions. After fixing this permission the software worked.
AFAIK, ZIP files can't carry permission data for each file (like TAR does, for example), but extracting the same file above using Mac OS X "Archive" worked great (without having to change permissions manually).
Is this an issue in Keka?

Thanks in advance and sorry for my bad English.

Re: Bug Extracting ZIP

Posted: Thu Oct 11, 2012 5:46 am
by kadr
like you said, ZIP does not store file permissions. Just because OSX Archive utility sets permissions to X, does not mean its correct behavior ;)

Re: Bug Extracting ZIP

Posted: Wed Oct 17, 2012 9:24 am
by aone
This is a known bug. More info here: